import re
regex = re.compile(r"^[\p{L}\d!#$%&'*+/=?^_`{|}~-]+(?:\.[\p{L}\d!#$%&'*+/=?^_`{|}~-]+)*@[\p{L}\d]+(?:[.-][\p{L}\d]+)*\.\p{L}{2,}$", flags=re.UNICODE | re.MULTILINE)
test_str = ("test.user@example.com\n"
"test-user@ex-ample.com\n"
"test.user+123@example.com\n"
"dörte@sörensen.example.com\n"
"χρήστης@παράδειγμα.ελ\n"
"иван@поща.бг\n"
"خالد@الدوحة.قط\n"
"שלום@דוגמה.ישראל")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")