# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"0*([0-9a-fA-F]+)"/"\1"/gm;t' <<< "original_ref_list = [\"005a004\",
\"018b003\",
\"007a029\",
\"105a015\",
\"0000000\",]"