import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"0*([0-9a-fA-F]+)\"";
final String string = "original_ref_list = [\"005a004\",\n"
+ " \"018b003\",\n"
+ " \"007a029\",\n"
+ " \"105a015\",\n"
+ " \"0000000\",]";
final String subst = "\"\\1\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}