// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"0*([0-9a-fA-F]+)""#).unwrap();
let string = "original_ref_list = [\"005a004\",
\"018b003\",
\"007a029\",
\"105a015\",
\"0000000\",]";
let substitution = "\"\\1\"";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}