# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"0*([0-9a-fA-F]+)\""
test_str = ("original_ref_list = [\"005a004\",\n"
" \"018b003\",\n"
" \"007a029\",\n"
" \"105a015\",\n"
" \"0000000\",]")
subst = "\"\\1\""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.