re = /"0*([0-9a-fA-F]+)"/m
str = 'original_ref_list = ["005a004",
"018b003",
"007a029",
"105a015",
"0000000",]'
subst = '"\\1"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result