use strict;
my $str = 'original_ref_list = ["005a004",
"018b003",
"007a029",
"105a015",
"0000000",]';
my $regex = qr/"0*([0-9a-fA-F]+)"/mp;
my $subst = '"\\1"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";