import Foundation
let pattern = #""0*([0-9a-fA-F]+)""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
original_ref_list = ["005a004",
"018b003",
"007a029",
"105a015",
"0000000",]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""\1""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)