const regex = /"0*([0-9a-fA-F]+)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"0*([0-9a-fA-F]+)"', 'gm')
const str = `original_ref_list = ["005a004",
"018b003",
"007a029",
"105a015",
"0000000",]`;
const subst = `"\1"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);