using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?://\Qeem.mydomain.com\E/\K\d{4}/\d{2}/([^""'>]*?)\.html";
string substitution = @"energy-environment-blog/$1";
string input = @"Hello there how are <a
href=""http://eem.mydomain.com/2015/06/court-compels-epa-to-
respond.html"">some link name</a> there how are there how are
<a href=""http://eem.mydomain.com/2014/03/wv-clean-air-act-case.html"">another
link name</a>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}