use strict;
my $str = 'Hello there how are <a
href="http://eem.mydomain.com/2015/06/court-compels-epa-to-
respond.html">some link name</a> there how are there how are
<a href="http://eem.mydomain.com/2014/03/wv-clean-air-act-case.html">another
link name</a>';
my $regex = qr~https?://\Qeem.mydomain.com\E/\K\d{4}/\d{2}/([^"'>]*?)\.html~p;
my $subst = 'energy-environment-blog/$1';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";