const regex = new RegExp('https?://\\Qeem.mydomain.com\\E/\\K\\d{4}/\\d{2}/([^"\\'>]*?)\\.html', 'g')
const str = `Hello there how are <a
href="http://eem.mydomain.com/2015/06/court-compels-epa-to-
respond.html">some link name</a> there how are there how are
<a href="http://eem.mydomain.com/2014/03/wv-clean-air-act-case.html">another
link name</a>`;
const subst = `energy-environment-blog/$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);