import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?://\\Qeem.mydomain.com\\E/\\K\\d{4}/\\d{2}/([^\"'>]*?)\\.html";
final String string = "Hello there how are <a \n"
+ "href=\"http://eem.mydomain.com/2015/06/court-compels-epa-to-\n"
+ "respond.html\">some link name</a> there how are there how are \n"
+ "<a href=\"http://eem.mydomain.com/2014/03/wv-clean-air-act-case.html\">another \n"
+ "link name</a>";
final String subst = "energy-environment-blog/$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}