$re = '~https?://\Qeem.mydomain.com\E/\K\d{4}/\d{2}/([^"\'>]*?)\.html~';
$str = 'Hello there how are <a
href="http://eem.mydomain.com/2015/06/court-compels-epa-to-
respond.html">some link name</a> there how are there how are
<a href="http://eem.mydomain.com/2014/03/wv-clean-air-act-case.html">another
link name</a>';
$subst = "energy-environment-blog/$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;