import Foundation
let pattern = #"https?://\Qeem.mydomain.com\E/\K\d{4}/\d{2}/([^"'>]*?)\.html"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Hello there how are <a
href="http://eem.mydomain.com/2015/06/court-compels-epa-to-
respond.html">some link name</a> there how are there how are
<a href="http://eem.mydomain.com/2014/03/wv-clean-air-act-case.html">another
link name</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"energy-environment-blog/$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)