# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<img[^>]*>(*SKIP)(*FAIL)|.//gs;t' <<< "<html><head></head><body><img src='image.jpg'></body></html>"