// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)<img[^>]*>(*SKIP)(*FAIL)|.").unwrap();
let string = "<html><head></head><body><img src='image.jpg'></body></html>";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}