package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)<img[^>]*>(*SKIP)(*FAIL)|.`)
var str = `<html><head></head><body><img src='image.jpg'></body></html>`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}