using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img[^>]*>(*SKIP)(*FAIL)|.";
string substitution = @"";
string input = @"<html><head></head><body><img src='image.jpg'></body></html>";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}