$re = '/<img[^>]*>(*SKIP)(*FAIL)|./s';
$str = '<html><head></head><body><img src=\'image.jpg\'></body></html>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;