import Foundation
let pattern = #"<img[^>]*>(*SKIP)(*FAIL)|."#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"<html><head></head><body><img src='image.jpg'></body></html>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)