const regex = /<img[^>]*>(*SKIP)(*FAIL)|./gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img[^>]*>(*SKIP)(*FAIL)|.', 'gs')
const str = `<html><head></head><body><img src='image.jpg'></body></html>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);