#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)<img[^>]*>(*SKIP)(*FAIL)|."
Local $sString = "<html><head></head><body><img src='image.jpg'></body></html>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)