#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(0(1|2|3|7|8|9)\d{9})|(0(1|55|56)\d{8})|(0800\d{6})$"
Local $sString = "" & @CRLF & _
"01222222224" & @CRLF & _
"02111111111" & @CRLF & _
"03888888888" & @CRLF & _
"05544448888" & @CRLF & _
"05699995555" & @CRLF & _
"05899996666" & @CRLF & _
"07752300794" & @CRLF & _
"08585458745" & @CRLF & _
"09555888574" & @CRLF & _
"0169778888" & @CRLF & _
"0125478596" & @CRLF & _
"0163546835" & @CRLF & _
"0800222555" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")