// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(0(1|2|3|7|8|9)\d{9})|(0(1|55|56)\d{8})|(0800\d{6})$").unwrap();
let string = "
01222222224
02111111111
03888888888
05544448888
05699995555
05899996666
07752300794
08585458745
09555888574
0169778888
0125478596
0163546835
0800222555
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}