const regex = /^(0(1|2|3|7|8|9)\d{9})|(0(1|55|56)\d{8})|(0800\d{6})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(0(1|2|3|7|8|9)\\d{9})|(0(1|55|56)\\d{8})|(0800\\d{6})$', 'gm')
const str = `
01222222224
02111111111
03888888888
05544448888
05699995555
05899996666
07752300794
08585458745
09555888574
0169778888
0125478596
0163546835
0800222555
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}