# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(0(1|2|3|7|8|9)\d{9})|(0(1|55|56)\d{8})|(0800\d{6})$"
test_str = ("\n"
"01222222224\n"
"02111111111\n"
"03888888888\n"
"05544448888\n"
"05699995555\n"
"05899996666\n"
"07752300794\n"
"08585458745\n"
"09555888574\n"
"0169778888\n"
"0125478596\n"
"0163546835\n"
"0800222555\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.