import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(0(1|2|3|7|8|9)\\d{9})|(0(1|55|56)\\d{8})|(0800\\d{6})$";
final String string = "\n"
+ "01222222224\n"
+ "02111111111\n"
+ "03888888888\n"
+ "05544448888\n"
+ "05699995555\n"
+ "05899996666\n"
+ "07752300794\n"
+ "08585458745\n"
+ "09555888574\n"
+ "0169778888\n"
+ "0125478596\n"
+ "0163546835\n"
+ "0800222555\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}