use strict;
my $str = '
01222222224
02111111111
03888888888
05544448888
05699995555
05899996666
07752300794
08585458745
09555888574
0169778888
0125478596
0163546835
0800222555
';
my $regex = qr/^(0(1|2|3|7|8|9)\d{9})|(0(1|55|56)\d{8})|(0800\d{6})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}