package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(0(1|2|3|7|8|9)\d{9})|(0(1|55|56)\d{8})|(0800\d{6})$`)
var str = `
01222222224
02111111111
03888888888
05544448888
05699995555
05899996666
07752300794
08585458745
09555888574
0169778888
0125478596
0163546835
0800222555
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}