#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:[A-Z]+\*+|\G(?!^))\K\.(?=[^*]*\*)"
Local $sString = "AG**...**GG*.*" & @CRLF & _
"AG**...**GG*.*.G.*C.C"
Local $sSubst = "*"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)