import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[A-Z]+\\*+|\\G(?!^))\\K\\.(?=[^*]*\\*)";
final String string = "AG**...**GG*.*\n"
+ "AG**...**GG*.*.G.*C.C";
final String subst = "*";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}