import Foundation
let pattern = #"(?:[A-Z]+\*+|\G(?!^))\K\.(?=[^*]*\*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
AG**...**GG*.*
AG**...**GG*.*.G.*C.C
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"*"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)