import re
regex = re.compile(r"(?:[A-Z]+\*+|\G(?!^))\K\.(?=[^*]*\*)", flags=re.MULTILINE)
test_str = ("AG**...**GG*.*\n"
"AG**...**GG*.*.G.*C.C")
subst = "*"
result = regex.sub(subst, test_str)
if result:
print(result)