$re = '/(?:[A-Z]+\*+|\G(?!^))\K\.(?=[^*]*\*)/m';
$str = 'AG**...**GG*.*
AG**...**GG*.*.G.*C.C';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;