using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[A-Z]+\*+|\G(?!^))\K\.(?=[^*]*\*)";
string substitution = @"*";
string input = @"AG**...**GG*.*
AG**...**GG*.*.G.*C.C";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}