const regex = /(?:[A-Z]+\*+|\G(?!^))\K\.(?=[^*]*\*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[A-Z]+\\*+|\\G(?!^))\\K\\.(?=[^*]*\\*)', 'gm')
const str = `AG**...**GG*.*
AG**...**GG*.*.G.*C.C`;
const subst = `*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);