#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=[A-Za-z])\s(?=[A-Za-z])"
Local $sString = "ab cd 1234567 1234567 ef gh 1234567 1234567 ij kl - - - -"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)