const regex = /(?<=[A-Za-z])\s(?=[A-Za-z])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[A-Za-z])\\s(?=[A-Za-z])', 'gm')
const str = `ab cd 1234567 1234567 ef gh 1234567 1234567 ij kl - - - -`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);