using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[A-Za-z])\s(?=[A-Za-z])";
string substitution = @"";
string input = @"ab cd 1234567 1234567 ef gh 1234567 1234567 ij kl - - - -";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}