re = /(?<=[A-Za-z])\s(?=[A-Za-z])/m
str = 'ab cd 1234567 1234567 ef gh 1234567 1234567 ij kl - - - -'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result