import Foundation
let pattern = #"(?<=[A-Za-z])\s(?=[A-Za-z])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"ab cd 1234567 1234567 ef gh 1234567 1234567 ij kl - - - -"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)