$re = '/(?<=[A-Za-z])\s(?=[A-Za-z])/m';
$str = 'ab cd 1234567 1234567 ef gh 1234567 1234567 ij kl - - - -';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;