import re
regex = re.compile(r"(?<=[A-Za-z])\s(?=[A-Za-z])", flags=re.MULTILINE)
test_str = "ab cd 1234567 1234567 ef gh 1234567 1234567 ij kl - - - -"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)