#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mu)\b((?:\w+(?:'\w+)?)(?:-(?:\w+(?:'\w+)?))*)\b"
Local $sString = "aguardaram-se" & @CRLF & _
"guarda-chuva" & @CRLF & _
"gota-d'água" & @CRLF & _
"d'água" & @CRLF & _
"água" & @CRLF & _
"teste" & @CRLF & _
"-" & @CRLF & _
"a_b" & @CRLF & _
"123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")