re = /\b((?:\w+(?:'\w+)?)(?:-(?:\w+(?:'\w+)?))*)\b/m
str = 'aguardaram-se
guarda-chuva
gota-d\'água
d\'água
água
teste
-
a_b
123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end