using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b((?:\w+(?:'\w+)?)(?:-(?:\w+(?:'\w+)?))*)\b";
string input = @"aguardaram-se
guarda-chuva
gota-d'água
d'água
água
teste
-
a_b
123";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}