import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b((?:\\w+(?:'\\w+)?)(?:-(?:\\w+(?:'\\w+)?))*)\\b";
final String string = "aguardaram-se\n"
+ "guarda-chuva\n"
+ "gota-d'água\n"
+ "d'água\n"
+ "água\n"
+ "teste\n"
+ "-\n"
+ "a_b\n"
+ "123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}