// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mu)\b((?:\w+(?:'\w+)?)(?:-(?:\w+(?:'\w+)?))*)\b").unwrap();
let string = "aguardaram-se
guarda-chuva
gota-d'água
d'água
água
teste
-
a_b
123";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}