$re = '/\b((?:\w+(?:\'\w+)?)(?:-(?:\w+(?:\'\w+)?))*)\b/mu';
$str = 'aguardaram-se
guarda-chuva
gota-d\'água
d\'água
água
teste
-
a_b
123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);